Fandom

D'jinni Wiki

Editor configuration

1,297pages on
this wiki
Add New Page
Talk0 Share

Run the Editor. Normally it looks as follows:

Configuration1

At the moment you have access only to the main menu of the D’jinni Editor and to the Event Register window of the Aurora log. Later, the number of the opened windows depends only on your preferences and settings. Before I describe the editor’s interface in detail, however, let us look at its settings. In order to do that, choose Options in the Tools menu:

Configuration2

This will open the Global Properties window:

Configuration3

This window contains the editor’s customizable options. The window is divided into the following section: D’jinni, Directories, Area Editor, Build Wizard, Conversation Editor, Cutscene Editor, Game Debugging, Module Explorer, Resource Explorer, String Editor, Scene Editor Camera Movement Keys and String Database. To move more easily between the sections, you can minimize them by clicking on a small '-' signs located next to the section names:

Configuration4

To maximize a previously minimized section, click on the small '+' sign located next to that section’s name:

Configuration5

The window is divided into two columns – the left column contains the name of an option, the right-hand column holds its value. The list is quite long, thus you can scroll up and down using the bar on the right:

Configuration6

Here we’ll describe the respective options available in the Global Properties window:

D’jinni Section:
This section contains the basic options of the D’jinni Editor.

  • Documents loaded at startup. Contains the names of the documents run when the editor is started.
  • Items shown in recently used lists. Determines the number of the entries shown in the recently used documents list. The value 0 means that no recently used documents will be shown.
  • Show recent files in File menu. Determines whether the recently used files are shown in the File menu. The values you can assign to this option are:
- False – recently used files are not shown in the File menu,
- True – recently used files are shown in the File menu.
  • Reopen last edited documents after restart. Determines whether the recently edited documents will be opened the next time you run the editor. The values you can assign to this option are:
- False – edited documents will not be automatically opened when you restart the editor,
- True – edited documents will be automatically opened when you restart the editor.
  • Open log on error. Determines whether the Event Register window will open after an error has occurred. The values you can assign to this option are:
- False – Event Register window will not automatically open when an error occurs,
- True – Event Register window will automatically open when an error occurs.


Directories Section:
This section contains the names of the folders assigned to the given elements of the D’jinni Editor.

  • Textures. Contains the name of the textures folder.
  • Materials. Contains the name of the materials folder.
  • Meshes. Contains the name of the 3D object models folder.
  • Sounds. Contains the name of the sounds folder.
  • Quests. Contains the name of the quests folder.
  • Modules. Contains the name of the modules folder.


Area Editor Section:
This section contains options related to the Area Editor. It constitutes one of the most important parts of the D’jinni Editor. Using this editor you can set objects and their attributes.

  • Show geometry hitcheck info in status bar. Determines whether the status bar is to show the cursor’s geometry coordinates. The status bar is located at the bottom of the editor. The values you can assign to this option are:
- False – coordinates will not be shown,
- True – coordinates will be shown.
  • Show navigation geometry hitcheck info in status bar. Determines whether the status bar is to show the cursor’s navigation coordinates. The values you can assign to this option are:
- False – coordinates will not be shown,
- True – coordinates will be shown.
  • Use walkmesh material mask in hitcheck. Determines whether the geometry material is to be used during navigation. The values you can assign to this option are:
- False – material will not be used,
- True – material will be used.
  • Show geometry hitcheck info under mouse cursor. Determines whether the geometry coordinates are to appear under the mouse cursor. The values you can assign to this option are:
- False – coordinates are not to appear,
- True – coordinates are to appear.
  • Show navigation geometry hitcheck under mouse cursor. This option determines whether the navigation coordinates are to appear by the cursor. The values you can assign to this option are:
- False – coordinates are not to appear,
- True – coordinates are to appear.
  • Real-time instance placement verification. Determines whether the distribution of the spawn points, action points and placeables is to be tested in real-time, i.e. while templates are being edited. The values you can assign to this option are:
- False – distribution will not be tested,
- True – distribution will be tested.


Build Wizard Section:
This section contains options related to the creation of various versions of the game. This doesn’t really concern us.

  • Compiler Path. Contains the path to the Compiler.
  • Log File Path. Contains the path to the Event Log file.
  • Log File Enabled. Determines whether the compiled events will be saved in the Event Log file. The values you can assign to this option are:
- False – events will not be saved in the Event Log file,
- True – events will be saved in the Event Log file.


Conversation Editor Section:
This section contains options related to the Conversation Editor (dialogue). In this editor you create conversations between characters.

  • Show full conversation entries. Determines whether the full entries will appear during the creation of a conversation. The values you can assign to this option are:
- False – full entries will not be shown,
- True – full entries will be shown.


Cutscene Editor Section:
This section contains options related to the Movie Editor. In this editor you create movies using The Witcher’s game engine.

  • Autosave enabled. Determines whether the currently opened movie will be auto-saved. The values you can assign to this option are:
- False – auto-save is off,
- True – auto-save is on.
  • Autosave interval. Contains the time (in minutes) after which the currently opened movie will be auto-saved.


Game Debugging Section:
This section contains options related to module testing.

  • Show all quest on module start. Determines whether all the quests will be shown when the module is started. The values you can assign to this option are:
- False – quests will not be shown,
- True – quests will be shown.
  • Enable ‘BestPerformance’ mode on start. Determines whether the best performance mode will be automatically enabled when the module is started. The values you can assign to this option are:
- False – best performance mode will not be enabled,
- True – best performance mode will be enabled.


Module Explorer Section:
This section contains options related to the Module Explorer. The Module Explorer is used when you create or edit an area.

  • Load last loaded module at startup. Determines whether the last used module will be loaded again on D’jinni Editor startup. The values you can assign to this option are:
- False – last used module will not be loaded,
- True – last used module will be loaded automatically.
  • Always reload the module on game end. Determines whether the currently in-use module will be reloaded when you finish testing it at the D’jinni Editor level. The values you can assign to this option are:
- False – module will not be reloaded,
- True – module will be reloaded automatically.


Resources Explorer Section:
This section contains options related to the Resources Explorer. This explorer manages the files/resources needed to create new modules.

  • TortoiseProc Path. Contains the access path to the program supervising the teamwork.
  • Silent scripts compilation. Determines whether scripts will be compiled first, and then undergo the teamwork supervision. The values you can assign to this option are:
- False – scripts will not be compiled before the teamwork supervision,
- True – scripts will be compiled before the teamwork supervision.


String Editor Section:
This section contains the options related to the String Editor. This editor is used to translate texts into various languages.

  • Database path. Contains the access path to the String Database.
  • Lock path. Contains the access path to the Locked (secured) String Database.


Scene Editor Camera Movement Key Section:
This section contains key settings used to move the camera in the Area Editor.

  • Forward. Move the camera forward.
  • Backward. Move the camera backwards.
  • StrafeLeft. Strafe the camera left.
  • StrafeRight. Strafe the camera right.
  • Upward. Move the camera upwards.
  • Downward. Move the camera downwards.
  • PitchUp. Pitch the camera up.
  • PitchDown. Pitch the camera down.
  • YawLeft. Yaw the camera left.
  • YawRight. Yaw the camera right.


String Database Section:
This section contains options related to the String Database.

  • String Database path. Contains the access path to the String Database.


If you wish to change a given option, click on the OK button in the Global Properties window. I recommend, however, leaving the default settings.

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.