FANDOM


OverviewEdit

D'jinni is a comprehensive development environment used for creating new modules. The developers used it themselves during the creation of the game, so anyone who played The Witcher has seen what this editor is capable of. Its characteristic features are:

  • All-in-one editor – the D’jinni Editor consists of so-called plug-ins. Using the D’jinni you can create templates for characters, conversations, quests, although in truth, each of these tasks draws on an independent editor,
  • Multi-tasking architecture – allows you to work on several files at once, simultaneously creating a new characters, quests or conversations,
  • Real time testing and debugging – you can test the module you are creating in real time, check how it works, etc. Additionally, you have a comprehensive testing program at your disposal,
  • Flexibility – allows you to adjust the work environment to your personal needs.


Despite appearances, the editor is not hard to use and it takes just around an hour to get comfortable with its basic functions.

Quick tipsEdit

After installing patch 1.3 with module editor, you’ll find Djinni in C:\Program Files\The Witcher\System.

  • Click djinni!.exe and wait until the program loads. Now you can see a large window with some menus. Let’s start with customizing it a bit. First click on a View > Utility windows > Properties. This window will show you important information about quests, dialog lines etc. Next window you have to activate is Resource explorer, Quest explorer, Game Object Inspector and Favourites (you can add folders to Favourites by right clicking on it and choosing Add to Favourites).
  • Click on a Resource explorer tab. Here you have a list of folders that you can use. You can find them in C:\Program Files\The Witcher\Data and in this folder you can save your own files. In Quest Explorer tab you can look at all the quests (unfold the Quest Database list and mark witch quests you’d like to see).
  • Now we should activate some useful toolbars. Click View > Toolbars > Game. This bar allows you to play, pause and stop the game and also to see it at full screen (you can also use alt + Tab to do this). Let’s activate also a Game Time toolbar, so we could set a different hour when playing the game.
  • So you’d like to create your own module, right? Click on Module > New module. A Module Explorer tab appears automatically. Right click on Areas in Module Explorer, choose New area, and then Meshes > Locations> GL22 > gl22.set. Enter name for your area (this is an Old Manor location) and confirm. You have just added first area to your module! Now click on a “+” near the area name and click on Edit Area - you have this area opened for editing, you can add decorations, spawnpoints etc. Right click on an area name and add new layer. You can place a different types of object on different layers so they will be easier to find (eg. NPC spawn points and actionpoints on a Story layer, gameplay monsters on a Gameplay layer, etc.). If you want to define the exact place where the player will appear after launching the module, place a Start point from area editor menu.
  • After making some changes we should save our module. Click on Module > Save module and save it in a directory C:\Documents and Settings\All Users\The Witcher. Now close the area editor and press F5. The game will start. Choose New Game > New adventures and choose your new module from the list. Choose the difficulty and camera settings and watch your module loading. If you didn’t set a skybox, it’s pitch black. Click on a Render > Ambient > Max ambient to see Geralt and all the surroundings.
  • That’s it, you created your first module, congratulations!

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.